Skip to main content
Skip table of contents

Support matrix (PostgreSQL)

Refer to the following support matrices to ensure compatibility between the environment, database, connector, and Delphix Continuous Data Engine.

Compatible upgrades have a green Y, while incompatible upgrades show a red N.

Per Delphix Support Policies, when a minor release is certified, all the patch releases falling under that minor release are also considered certified.

Environment and database compatibility

Operating system

The PostgreSQL connector is certified for use in source, staging, and target environments with the following operating systems and database versions.

OS version

Database version (open-source & EDB)

9.4.x

9.5.x

9.6.x

10.x

11.x

12.x

13.x

14.x

15.x

RHEL/CentOS 7.3

Y

Y

Y

Y

Y

Y

N

N

N

RHEL/CentOS 7.4

Y

Y

Y

Y

Y

Y

N

N

N

RHEL/CentOS 7.5

Y

Y

Y

Y

Y

Y

N

N

N

RHEL/CentOS 7.6

Y

Y

Y

Y

Y

Y

N

N

N

RHEL/CentOS 7.7

Y

Y

Y

Y

Y

Y

N

N

N

RHEL/CentOS 7.8

N

N

Y

Y

Y

Y

N

N

N

RHEL 7.9

N

N

Y

Y

Y

Y

Y

Y

N

Centos 7.9

N

N

N

N

N

Y

Y

Y

N

RHEL 8.0

N

N

N

N

N

Y

Y

Y

Y

RHEL 8.1

N

N

N

N

N

Y

Y

Y

Y

RHEL 8.2

N

N

N

N

N

Y

Y

Y

Y

RHEL 8.3

N

N

N

N

N

Y

Y

Y

Y

RHEL 8.4

N

N

N

N

N

Y

Y

Y

Y

RHEL 8.5

N

N

N

N

N

Y

Y

Y

Y

RHEL 8.6

N

N

N

N

N

Y

Y

Y

Y

RHEL 8.7

N

N

N

N

N

Y

Y

Y

Y

RHEL 8.8

N

N

N

N

N

Y

Y

Y

Y

RHEL 8.9

N

N

N

N

N

Y

Y

Y

Y

RHEL 9.0

N

N

N

N

N

N

N

N

Y

SUSE 11

Y

N

N

N

N

N

N

N

N

SUSE 12

Y

Y

Y

Y

Y

N

N

N

N

SUSE 15

N

N

N

N

N

N

Y

N

N

SUSE 15SP3

N

N

N

N

N

N

Y

N

N

Ubuntu 16.04

N

N

N

Y

N

N

N

N

N

Ubuntu 18.04

N

N

N

Y

Y

Y

Y

Y

Y

“x” represents the minor version.

·   SUSE 15SP3 is certified on Power 8.

·   Additionally, ensure that either libncurses.5 or libncurses.6 is installed on the environment to support both RHEL and SUSE. For actionable steps, refer to KBA 5622.

Supported Cloud Platform-as-a-Service (PaaS) database services

The PostgreSQL connector is certified for use with the following cloud PaaS database services and versions. 

A Cloud PaaS database service cannot be used as staging or target environments due to strict limitations imposed by the cloud vendors. In these cases, the Cloud PaaS database service can be used only as a source, and self-managed hosts, with a supported operating system and equivalent open-source PostgreSQL database versions, must be used for the staging and target environments.  We recommend the Delphix Continuous Data Engine, staging, and target environments be hosted in the same Cloud and region as the PaaS database service.

Cloud database service

Database version

11

12

13

14

15

Amazon Aurora PostgreSQL

Y

Y

Y

Y

Y

Amazon RDS PostgreSQL

Y

Y

Y

Y

Y

Azure Flexible Server

Y

Y

Y

Y

N

Only the single DB ingestion feature is supported for the cloud vendors using PostgreSQL through the pg_dump/pg_restore method with Staging Pull. With Staging Push, other ingestion methods may be possible.

If you wish to combine multiple individual Cloud PaaS databases into a single PostgreSQL instance, it is possible to do so with Staging Push. In this scenario, the individual databases are combined and restored into a single, common staging instance, resulting in one dSource which contains multiple databases, and is accessed via one HTTP port.

PostgreSQL connector and Delphix Continuous Data Engine compatibility

The PostgreSQL connector versions are certified to work with the following Delphix Continuous Data Engines.

Engine version

Connector version

1.4.1

1.4.2

1.4.3

1.4.4

1.5.0

1.5.1

2.0.0

2.1.0

2.1.1

3.0.0

3.1.0

3.2.0

4.0.0

4.1.0

4.1.1

4.2.0

4.2.1

4.2.2

6.0.0.x

Y

Y

Y

Y

Y

Y

N

N

N

N

N

N

N

N

N

N

N

N

6.0.1.x

Y

Y

Y

Y

Y

Y

N

N

N

N

N

N

N

N

N

N

N

N

6.0.2.x

Y

Y

Y

Y

Y

Y

N

N

N

N

N

N

N

N

N

N

N

N

6.0.3.x

Y

Y

Y

Y

Y

Y

N

N

N

N

N

N

N

N

N

N

N

N

6.0.4.x

Y

Y

Y

Y

Y

Y

N

N

N

N

N

N

N

N

N

N

N

N

6.0.5.x

Y

Y

Y

Y

Y

Y

N

N

N

N

N

N

N

N

N

N

N

N

6.0.6.x

Y

Y

Y

Y

Y

Y

N

N

N

N

N

N

N

N

N

N

N

N

6.0.7.x

Y

Y

Y

Y

Y

Y

N

N

N

N

N

N

N

N

N

N

N

N

6.0.8.x

Y

Y

Y

Y

Y

Y

N

N

N

N

N

N

N

N

N

N

N

N

6.0.9.x

Y

Y

Y

Y

Y

Y

N

N

N

N

N

N

N

N

N

N

N

N

6.0.10.x

Y

Y

Y

Y

Y

Y

N

N

N

N

N

N

N

N

N

N

N

N

6.0.11.x

Y

Y

Y

Y

Y

Y

N

N

N

N

N

N

N

N

N

N

N

N

6.0.12.x

Y

Y

Y

Y

Y

Y

N

N

N

N

N

N

N

N

N

N

N

N

6.0.13.x

Y

Y

Y

Y

Y

Y

N

N

N

N

N

N

N

N

N

N

N

N

6.0.14.x

Y

Y

Y

Y

Y

Y

Y

Y

Y

N

N

N

N

N

N

N

N

N

6.0.15.x

Y

Y

Y

Y

Y

Y

Y

Y

Y

Y

N

N

N

N

N

N

N

N

6.0.16.x

Y

Y

Y

Y

Y

Y

Y

Y

Y

Y

Y

Y

Y

Y

Y

Y

Y

Y

6.0.17.x

Y

Y

Y

Y

Y

Y

Y

Y

Y

Y

Y

Y

Y

Y

Y

Y

Y

Y

7.0.0.x

N

N

N

N

N

N

Y

Y

Y

Y

Y

Y

Y

Y

Y

Y

Y

Y

8.0.0.x

N

N

N

N

N

N

Y

Y

Y

Y

Y

Y

Y

Y

Y

Y

Y

Y

9.0.0.x

N

N

N

N

N

N

Y

Y

Y

Y

Y

Y

Y

Y

Y

Y

Y

Y

10.0.0.x

N

N

N

N

N

N

Y

Y

Y

Y

Y

Y

Y

Y

Y

Y

Y

Y

11.0.0.x

N

N

N

N

N

N

Y

Y

Y

Y

Y

Y

Y

Y

Y

Y

Y

Y

12.0.0.x

N

N

N

N

N

N

Y

Y

Y

Y

Y

Y

Y

Y

Y

Y

Y

Y

13.0.0.x

N

N

N

N

N

N

Y

Y

Y

Y

Y

Y

Y

Y

Y

Y

Y

Y

14.0.0.x

N

N

N

N

N

N

Y

Y

Y

Y

Y

Y

Y

Y

Y

Y

Y

Y

15.0.0.x

N

N

N

N

N

N

Y

Y

Y

Y

Y

Y

Y

Y

Y

Y

Y

Y

16.0.0.x

N

N

N

N

N

N

Y

Y

Y

Y

Y

Y

Y

Y

Y

Y

Y

Y

17.0.0.x

N

N

N

N

N

N

Y

Y

Y

Y

Y

Y

Y

Y

Y

Y

Y

Y

18.0.0.x

N

N

N

N

N

N

Y

Y

Y

Y

Y

Y

Y

Y

Y

Y

Y

Y

19.0.0.x

N

N

N

N

N

N

Y

Y

Y

Y

Y

Y

Y

Y

Y

Y

Y

Y

20.0.0.x

N

N

N

N

N

N

Y

Y

Y

Y

Y

Y

Y

Y

Y

Y

Y

Y

For more information, refer to the Delphix End of Support policy to determine whether a connector version is in primary, extended, or legacy support. Contact Delphix customer support with any questions.

JavaScript errors detected

Please note, these errors can depend on your browser setup.

If this problem persists, please contact our support.